All purchases fail

3 days ago I switched from my GIA to an ISA and now I cannot purchase any stock in any currency for any amount. I tried deleting and reinstall the app, switched from WiFi to roaming and don’t use a VPN. All stock purchases fail almost instantly after selecting the amount I want to buy. I get asked to try again but nothing changes. With my GIA I never had this problem.

Restart app, restart phone, delete app cache.
Try in this order.

Tried it. Didn’t work.

I assume you deposited funds into your ISA and they were ready to deploy.

Were the stocks you experiencing high volatility?

This happened to me in the past for this reason

I transferred money from my GIA to the new ISA. Only had 3 stocks which I closed and settled. Then tried buying those same 3 stocks again and none worked, not do any others. Not sure what u mean by high visibility.

I wasn’t aware you could transfer between accounts

What stocks were you trying to buy?

Next time you try to buy and it fails take a screenshot, typically you can work out why it failed.

Were the prices going up or down very fast?

Sometimes the system doesn’t execute the order if experiencing high volatility

See how you get on today after the markets open, this sounds like something that needs to click into place with cleared fund etc.

If you didn’t manage to buy Darktrace today at that price then you’ve already saved some money.