Cant make an account

Ive been trying to make an account for the last week and each time I get to the last stage it says the app is experiencing technical difficulties. I’ve deleted the app and reinstalled it I’ve cleared the cache and restarted my phone but each time it says experiencing technical difficulties. I have an iPhone XR which is up to date


I emallied hello@freetrade.op twice in the last week and they haven’t got back to me NEED HELP.

1 Like

Hi @Abiirah

Have you tried deleted the app and reinstalling?

Do you have access to another device to see if that works?

Have you got the latest version of the app and iOS?

There are thousands of sign ups a day so it might be a device issue.

Let us know how you get on.

1 Like

Ive tried installing it on another iPhone and got the same error message, I reinstalled and installed it multiple times and got the error message, I have the most up to date version of freetrade and IOS :frowning:

Have you had an account previously? Whether you decided to close it, or started a previous sign-up to use Freetrade If so, that could be why and you would need to wait for support to re-open the old account.

I would double check the email address you have used to ensure that you have been emailing the correct email address!

2 Likes

Search all of your inboxes for Freetrade or Freetrade investment income received. You might find you’ve got an account already?

The email address just to make sure is

Hello@freetrade.io

2 Likes

UPDATE: I’ve tried opening a new email address and open a new account. It got me to enter my details and started creating the account and then went back to the error message screen. Also when I download the app it doesn’t give a sign in option just a create account option.

Are you in the UK? or using a VPN? That could potentially cause an issue.

I do live in the UK but don’t use a vpn