How the hell do I register? Update: solved

So I’ve entered my email over what seems like 100 times to in the app, and have still not received any so called ‘Magic Link’? Can’t get through to an actual person to explain this… so have resorted to this community login, just to get some feedback? So any advice would be appreciated.
As I say, it seems my email is either not being recognised or just ignored by their system??

Have you checked your spam/promotions folder?

Yes. No luck… double checked email address. Everything is right? Just not receiving the link email confirmation? I’m out of ideas?

Do you use an email? This was a problem over on the Monzo forum where there was a second spam folder not visible via the phone app, you had to use the web access.

1 Like

Question: do you actually have a FT account, and are just trying to login to it, or have you yet to create one?

No I don’t! I have a commonly used email address. One of which I have used multiple times in other apps, with verification procedures not unlike the ones Freetrade exhibit, so would this app not do the same? Has there been a cap on members? I hun isn’t that evident within the app announcement pages? I’m at a complete loss! 2 days know and no coms from the developers? Frustrating!!!

The developers are not about to message you. Get a grip.

If you’re not getting magic emails at all, then there will be a reason. Either they are going to spam or they are not being received at all, or they are not being generated. Either way your only option will be to contact FT via email (as you cannot login to the app).

If it’s a Microsoft Exchange hosted email, it was down to their overzealous rules. I had a similar issue and Freetrade were great supporting getting it resolved by email.

Thankyou Jasejase. I knew I couldn’t be the only one with this issue. Unfortunately the email on your 2nd speech bubble bounces back. I just get a email cannot be sent! But I’ll try to do the same thing and reach out.

I’m understanding this doesn’t sound so helpful, but if your provider doesn’t allow you to send to then it’s most likely an issue with your provider receiving emails from this domain too.

Could you try signing up with an email address from a different provider?

Thanks for everyone’s help. I have managed to figure out why I couldn’t see it. Many thanks to you too Jasejase. Very helpful.