I can't get passed create an account

Hello, I am a new user to freetrade and upon trying to sign up for the app I always get the same error message “something has gone wrong. Freetrade is currently unavailable. We are working to fix the issue, please try again later”. I have a Google pixel 4a with Android 12, I have tried deleting and reinstalling the app countless times, I have made new emails and tried signing up with those, I have also tried another device, it’s a Samsung tablet, also with the latest software update and I have tried deleting and reinstalling on there but I still get the exact same error message on both devices, I have tried signing up for over a week now to see if it’d work with time but nothing still.
Someone please help!

1 Like

Hi @NotOllieB

You’ve done most of what is suggested the only thing you could try is turning off WiFi. It’s been reported that it has helped others in the past.

If it works can you jump on a let us know?

Thankyou I will try this and hopefully it’ll work but my connection is a very good and stable connection and I have tried signing up on 4G with no luck still.

1 Like

In this case you’re probably best to reach out to the team hello@freetrade.io

Currently between 1000 - 2500 people sign up a day so there is something we’re both missing I’d guess.

Good luck and let us know when you get it resolved yeah?

Alright thanks for the help mate :slight_smile: and yeah will let you know!

1 Like

Hello, just come back to this topic, i have tried everything now and nothing is working!

1 Like

Can I ask what Freetrade customer service have said about the problem?