MEGATHREAD: Bugs & Glitches

I created a new thread on this called RE: Freetrade app crashing on startup after latest update for IOS 12 please jump on there to add some weight to the situation! I know 2 other people personally having the same issue

Strange glitch this afternoon - unable to place orders as numeric keys not working. Only decimal point can be input. Running android - tried all usual solutions.

I’ve got the exact same glitch. Can’t enter any numbers to buy or sell.

Have reported it, tech is “on it”.

Will let you know of the outcome

Managed to get round using speech to text but had to place straight order rather than a limit as its the first selection. Got skanked on price, wish I’d waited :cry:

your mention of the decimal point, made me try putting in the point first, and then trying to add numbers in front of the point.

it worked.

not ideal but it is a temporary work around

1 Like

I have a weird issue where I can no longer add or remove stocks from my watchlist in the app, the button doesn’t seem to work.

Edit: I’ve tried clearing data and reinstalling the app but that hasn’t worked – anyone else experiencing the something similar?

Android. App version: 1.0.33519.

2 Likes

Same here FT :wave:

1 Like

Having the same exact problem since a couple days ago.
I have reported it through the chat but no reply yet.

1 Like

Hello :wave:

We’re aware of this issue and are rolling out a fix to the Google Playstore today.
The option to update your app should appear in the next couple of days. As soon as you see it you can download it and this issue should be resolved.

Sorry for the inconvenience caused !

2 Likes

Not sure if this has been reported but when switching between accounts on the app, there is delay where the up/down by figure takes the alternate account balance and compares it to the purchase price of the account being switched to, meaning it flashes up that I am a thousand odd up in my SIPP when I have only had it a couple of months. Switching from SIPP to ISA shows a considerable loss in the thousands before reverting to a much more palatable loss.

1 Like

An additional bug is when re-starting the app on iPhone 11 Pro Max the portfolio screen briefly flashes up before the keypad, potentially allowing someone to record your phone screen, then pause it, giving them access to how much money you had invested in particular shares.

I’ve noticed this too. The figures get momentarily mixed up when switching between accounts which can give you a right fright.

Here’s an example:

Thankfully, I’m only actually down 20p in my GIA today :joy:

1 Like

Well done for capturing that Rehpot. I didn’t have the patience!

Now that is a frightening amount to think you are down by!

1 Like

No worries. Sometimes it’s the opposite way around and I think I’m quids in for a second :laughing:

2 Likes

Unable to load my holdings at all since last 3 days. Uninstalled the app restarted mobile and reinstalled the app Hoewer no improvements. Basically unable to do any trades

I’m not sure this is a bug but it’s bugging me…

It seems like a fair few investment trusts are wrongly categorised as ‘finance’ under the insights/sector tab.

My Isa and Sipp are showing as 25%/15% in ‘finance’ but should both be 100% ‘ETFs, trusts and cash’.

1 Like

Some ETFs as well. I’ve flagged this multiple times, but no one changed it.

1 Like

Yeah, all ETFs and trusts should come under that one category really.

Another minor thing that doesn’t really matter in the grand scheme: can we get some consistency on logos? There’s about four different ones for Invesco ETFs, for example.

Am I imagining things of has the ability to add things to the watchlist disappeared on iOS ?

I see what they’ve done. It’s moved along with a new share button

IMG_0571

1 Like