Error when trying to buy whole shares

When trying to buy whole shares it is defaulting to fractional amounts. Is anyone else experiencing this today please?

Can’t say I ever try and buy whole shares, I just invest what I have. Is there any benefit of trying to stick to a whole share?

You never specify number of shares, you specify how much you want to spend and it converts that to the share value (number of shares you can buy for that amount); in the case of UK shares this will be a whole number.

1 Like

Indeed. Except that it’s giving me a fractional number where before it gave me a whole number and amended the amount I invested accordingly. It was working previously. Now the limit order (whole shares only) does the same as fractional shares option.

Is it giving you a fractional number on UK shares? Because it shouldn’t.

Fractional shares are live on US shares, so I’d expect that behaviour by default although I have no clue if it should be whole or fractional for Limit Orders. Perhaps someone with Plus can comment.

I have Plus.

There is no fractional shares option for UK shares. But there is whole and fractional for US. Except the whole seems to no longer be working.

You haven’t been able to select by number of shares since fractionals were introduced

There’s a long discussion on it here

You have only ever been able to input a money value, it’s just that before fractionals you got some change, now you get a fraction of a share

Thanks. I’m not trying to select by number of shares. But rather wanting to use the limit (whole shares) option so that my investment is rounded down to whole shares rather than fractions, as with the triggered fractional shares option. But this is seemingly not working when it was last week.

OK, I misunderstood you. in that case I don’t know

No problem. Thanks guys for all your insights. CS has responded that it is a bug, of which engineers are aware and in the process of fixing. Apparently the quoted fractional shares corrects itself to whole shares at purchase, although I’ve not tried this.

Edit:. I have now tried this and can confirm it purchases whole shares, despite showing as fractional.