Anyone else having issues with there portfolio page loading

Anyone else having issues with there portfolio page loading

2 Likes

Me.

I’ve got 12 investments. Sometimes the ‘show all’ button is there, but most of the time it isn’t

If the show all button is missing (on Android at least), then scroll up until you see the highlight to say you scrolled too far, and then scroll back down and it will appear. Same with limit orders if you have any set up.

Yup, my portfolio page not loading, been like that most of the day, I have uninstalled and reinstalled the app, no joy

I just checked. It’s working for me on Android, and had no problems all day up until 8pm when I was busy with something else and didn’t check it.

Yeah I’m having the same issue. Refused to load yesterday and same thing again this morning.

1 Like

Mines still not loading this morning, the other tabs are loading okay but the portfolio page still isn’t loading.

Having the same problem since yesterday portfolio page isn’t loading, since last night.

1 Like

Are you back in the app as yet? Mine still having a problem, also tried on another phone, same issue so this must be account related

1 Like

As of this morning mines still not working. I have reported the problem and let freetrade know others are having the same issue

1 Like

Hi All, sorry to hear you’re experiencing this issue.

Could you please direct message me your email addresses (the one linked to your Freetrade account). Thanks

Hi how do I directly message you?

or are you talking to send my email in this message tread?

Click on his face in the icon next to his name and then click Message.

Try clearing the cache retained then uninstall the app then reinstall… that’s what I just done and I worked

The engineering team have now fixed the bug. Please close your app and reopen it, it should be working fine. Sorry about the issue once again :pray:

I just updated the app, restarted the phone (iOS 14.5.1) etc. the problem keeps persisting and the portfolio page is stuck during loading.

Mine was loading okay but not updating, so the first couple of hours today showing yesterday’s close information, but it’s been fixed now.