Freetrade’s crowdfunding round is closed, the community invested £4m+ 🎉

Share your feedback here.

There’s no limit on how much you can invest :moneybag:

Check out FAQs here: Freetrade crowdfunding FAQs (5th round) ❔ & the previous discussion here :balloon:

Access the page here:

1 Like

Message came through in the app at 8.01, invested by 8.02!

So much easier than the last round!

1 Like

I didn’t get any message but I was told that my slot is between 8 - 8:30 am. :frowning:

Super smooth here, good work. I hope everyone (should they wish) gets their chance to invest.

And, of course, good luck to Freetrade!


The real scramble starts at 12, let’s see if Crowdcube can handle the demand!


All sorted using the email link to crowdcubes website.
I did have issues using the in app link as it kept closing FT page inside of crowdcubes app.
Has anyone had this problem?

Got the link couple of minutes after 8am but all was good from there on

1 Like

Yes we’re seeing issues with the iOS Crowdcube app at the moment. We’ve let them know & they’re looking into it.

In the meantime, it’s best to invest via the website instead :woman_technologist:

1 Like

Great to hear it was pain free! When you say app, you mean crowdcube’s app not free trade, right?

I’ve not received my email giving me my time slot & im in & out of meetings. I’d kept 11:00 free to invest, now not sure I’ll get the chance. If I have to wait till 12:00 & miss our on EIS my investment could end up costing me £1,000’s more in tax

Done, take over the world Freetrade.


I received the message through the freetrade app with a link to invest through the crowdcube app

If we have not yet received an email is that okay, or does that mean something has gone wrong?

I don’t think the fault is with Freetrade. When you click the link in Freetrades app it then opens Crowdcubes app and the Freetrade page briefly appears before disappearing.

But using the emailed link takes you to crowdcubes website where I had no problems investing.


0801 - message in freetrade app - clicked link to crowdcube - filled in boxes - complete by 0805.

Very easy process.

1 Like

Well, that didn’t got well at all. I knew it would suck when I got the 8-8:30 slot because that’s when I’m on my train, commuting into London through tunnels and dead spots.

As it stands I can’t even tell whether I invested or not. I got the reminder email and followed the link, which opened an investment page in my browser where it looked like I could just type in an amount and tap ‘invest’ as usual, but on doing that it wanted me to use a new card. It didn’t say why.

I tried my existing card, but it didn’t work and it didn’t say why not.

I tried via the Crowdcube app, but couldn’t find a way to get to an input screen.

So I went back to the email, but used a different browser and this time it told me the bank has blocked my card. I can’t fix that from the train. I thought payment wasn’t normally taken for about a week anyway, though. Perhaps I can fix it by then, but I can’t tell whether I’m in or missed out at this point.

Was very easy - I used the iOS Crowdcube app (from the link in FT app) with no problems! So much better than r4!


All done here, 8:30 - 9:00 slot. Used the in app message directly to Crowdcube app. Super fast, smooth and pain free. Congrats Freetrade and Crowdcube!


Hi @emalb,

Sometimes your bank will block the pre-authorisation on the card, so it might be worth contacting them directly to ask them to unblock your transaction.

Alternatively, could you try a different card? You can then change this via the app or the site once your investment has been made, and before payment is taken



Topped up with £500. :sunglasses:

No problems. Very smooth.