Allow users to change PIN/security timeout

Hi,

I often alternate between Freetrade, and share related news on my 'phone.

The Freetrade app automatically locks requiring PIN entry anywhere between 15 and 60 seconds whilst using the 'phone for something else.

Suggestion: allow users to change the timeout before lock.

Yes I agree. Also returning to the page you left instead of having to do a search again for for the last stock you were looking at!

1 Like

The last stock should be the first on recent views :+1:

and @sophie this is a security issue that is probably best left although I get your reasoning. My assumption is with the finger print tech becoming norm it is/will be instant opening to all sooner or later so not a real ambition.

1 Like

Even when you don’t leave the app, having to confirm for every single trade is annoying.

I have 15 US stocks in my portfolio, and typically I put £10 in most of these just after the US market opens before the prices change too much and then I decide which to put more into. Coupled with every time I switch to the app, it feels like I must enter my passcode at least 50 times per day.

The first day or so when it used the fingerprint it was OK, but it’s stopped doing that and always asks for a passcode now.

1 Like

I get your frustration, I bought about 90 stocks the other day across GIA, ISA and SIPP and had to fingerprint every time but I still think it is needed as a confirmation as it could be too easy to make an error if not in place. :+1:

Let’s be honest though, that is a nice problem in life to have :joy: :+1:

1 Like

Except it’s just muscle memory at this point and the other day I almost accidentally bought £XXXX of shares instead of £10.

1 Like

:joy: :man_facepalming: I get that but guess it would happen far more often the other way around. I would guess security is the 100% priority and this idea is no doubt not worth the risk.

Hi,

I have an iphone SE, and I refuse to use a phone with face unlock or fingerprints.

I consider 'phone biometrics and Freetrade app timeout excessive and disproportionate.

We need a PIN to place an order. Needing it to just open the appx view portfolios, or search for stock, is silly.

Transferwise doesn’t even ask me for a passcode (thankfully), and most other banking apps have much longer timeouts (e.g HSBC Virgin Money). Barclays is pretty short, but still longer than Freetrade.

I prefer functionality first, and security second. If banking applications have longer timeouts, then Freetrade looks like too long. 15 to 30 seconds is ridiculous. It’s not long enough to watch live ticks, and flip back to Freetrade to press Confirm. How about 120 seconds?

It adds an extra layer of stress and bureaucracy.

I’m happy to enter the PIN to view the portfolio the first time. That makes sense because you might not want people who have access to your phone to see your portfolio. But definitely agree that once you’ve done that, there’s no point asking repeatedly. Timeouts make sense, especially as if you’re worried about leaving it unlocked when lending someone the phone, you can easily just close the app.

1 Like

I come back to my original point and that is the vast majority of people will use finger print so it is instant and very secure :+1: I can honestly say I have never even thought about the time to unlock since I’ve been using the app as it is so quick.

If you don’t want to use fingerprint tech etc then you kind of put barriers in the way of the app being functional and I would imagine this is such a small % of people it won’t over ride the most important security protocols.

I would of thought the vast majority are of a “belt and braces” view regarding this and would rather it stay “as is”.

Fingerprints just stopped working for me after a couple of bad fingerprint reads. I get that a lot even unlocking the phone as my skin is pretty cracked on my fingers, but even though the phone has gone back to using fingerprints to unlock, the app hasn’t and there seems to be no way to re-enable it.

It’s not supported on my 'phone, and I shan’t buy a new 'phone to use the tech.

I use fingerprints to open the doors in the office. Worked until I cut my finger twice in the same week, and the I could not enter with fingerprints. Security team had to make an exception to my badge to enter a pin. Same could have happened with my 'phone had I have had fingerprints enabled. Could you be locked out of a 'phone after a car accident with facial injuries? I can always PIN. I am spouting exceptions, and these exceptions remain exceptional until these happen to you :slight_smile:

The app already falls back to PIN if the fingerprint fails (as does almost every app).

Like I say, this is a problem I always have - I have very dry skin so my fingers are always cracking and re-healing and it always confuses the fingerprint readers of every device I have. But when it does work, it is super nice.

Security is always over the top on everything. It will just get more annoying over time because developers always ignore common sense and go with fashion. I’ve just given in to defeat with it all.

1 Like

I guess the complaints of “it is too much hassle” do not outweigh the “security is not tight enough” arguments :+1: Personally, I don’t get how instant access to view or buy taking a whole 4 buttons or a single finger print is such an issue when you consider the security it brings :joy: :man_facepalming:

Never in history has it been so simple to trade but still complaints. If you have a car accident you have to press 4 buttons, big deal.

And security is only “over the top” until it’s too late and you suddenly realise it wasn’t and by then you realise how ridiculous that argument was :stuck_out_tongue_winking_eye:

2 Likes

Thx. I didn’t know.

Absolutely agree with you. I’m still fighting.

Well thank you very much Lemmy :+1: As a middle aged man I can’t remember being called fashionable so you made my day :stuck_out_tongue_winking_eye:

Who would of thought that security would be deemed a fashion choice?

1 Like

Fingerprint not working for me now either, with only PIN authentication available. Tried a reinstall but no joy.

2 Likes