ISA Transfers in Activity Feed

ISA Transfers into Freetrade are not shown in the Activity Feed. Please add them (and I assume ISA transfers out) into the Activity Feed so it shows a complete picture of account activity.

I previously mentioned this in the ISA transfer thread last year

But having recently done another ISA transfer, and there being no change in behaviour, thought I should note it down in an individual thread so it isn’t forgotten.

SIPP transfers aren’t shown either. I guess if they sort the one out for ISAs, they’ll do same for SIPPs.

TBH, I’d kind of prefer that funding activities (and presumably withdrawals) weren’t shown on this feed at all. It makes the MAX view pretty much useless for seeing the performance of my investments over time, as my funding over time completely dwarfs it.

Unless that just means I’m doing it wrong! :smiley:

But realistically, a lot of people will be drip feeding money into the ISA every month and for those who have multiple ISA years, it’s unlikely that the MAX view is useful if funding is included.

1 Like

I think transfers should be added too. Vote added.

What would be best is if the Activity Feed had a filter function. The default view would be “All” and this would show everything. But other options in the filter which could be checked/unchecked could be “deposits/withdrawals/transfers”, “buy/sell”, “dividends”, “statements”.

3 Likes

100% this.

If this is a huge amount of development effort and Freetrade just don’t think it’s worth investing that effort, then fair enough (though I can’t imagine it is that difficult - I assume the required data is already in the relevant database and it just needs taken through into the presentation layer… but I could be wrong :slight_smile:), but sometimes Freetrade CS act as if the current behaviour is a desirable feature and how you would expect things to be, which is clearly silly.

If funding an ISA through a bank transfer appears in the Activity feed, there is no plausible argument as to why ISA transfers in (and out) should not also appear there.