Transaction to buy US share did not complete

Hello all

New to investing. I tried to buy my first US share today but, after completing the form you have to complete to buy US shares, the transaction did not complete: the share has not been added, there is no record in the Activity section, and no money has been deducted from my account.

I tried to buy outside US market hours (from the UK) so is this the reason why the transaction did not complete or, as a first time buyer of US stock, am I being put through some sort of vetting?

It might also have been just a dodgy connection - I don’t know but I’m wondering if the US stock will suddenly appear in my portfolio in a week from now.


Welcome to the forum!

If you buy out of the market hours, your order will be placed and filled automatically slightly later - I believe US markets will tend to be at 3pm on a day that the market is open.

If you’ve not already since 3pm, have a look and see if the order has been fulfilled. If the money hasn’t been taken from your balance, it sounds like the request hasn’t fully completed and you may have to try again - could be worth getting in touch with support to make sure.

Check if you have queued orders in your portfolio tab.

Thanks for the advice. No, nothing in queued orders, Activity, no deductions from account, nil evidence the transaction completed; hopefully just a poor connection but next time I’ll buy when the US market is open.

Hey @DomA if the funds haven’t been blocked from your account - rest assured the trade didn’t go through and you won’t receive the shares.

Thanks :+1: