Unable to purchase shares due to the last updated time on my device

Hi, yesterday morning I wanted to purchase some stock as soon as the market opened. Its a stock I already own and wanted to increase my holding in.

When I attempted to buy it a minute or so after 8am I was advised I was unable to because the price on my device was last updated at 22:59 on 2nd of October. I was unable to make the purchase I wanted to get an early jump on because of this and had to wait until the price on the app updated which was something like 8:17 - 8:20.

Why should it matter when the price on my device was last updated?
I’m looking to buy at market price, not what the last price on my device was. I tried looking up the stock via discover to see if that would query the market price and refresh that on my device but it didn’t seem to make a difference

Are there time restrictions on when stock can be purchased? as I would expect to be able to buy between 8 and 16:30, and have done so regularly via another broker I use

While I appreciate there being a delay of around 15 mins before the price on the app might be updated, this shouldn’t impact my ability to buy.

Things like this, and the issue I’ve experienced today when trying to withdraw funds are reasons why I won’t be making the full move to freetrade- the least I expect to be able to do is trade during market hours.

It doesn’t affect your ability to buy, it just asks you if you’re sure (because of the price being from the day before). Maybe you just missed the ‘buy’ option after this popped up.

Thanks Seb, I did check multiple times and everytime I tried i was unable to buy.

The message appeared advising of the price on my local device and then when I acknowledged that nothing further was displayed.

I think the app remembered the amount I wanted to invest and I could press buy again to try the purchase again, I dont think I would’ve been able to do this if I was being asked if I was sure if I wanted to continue.

Weird issue. Maybe try to raise it in the in-app chat. Possibly try it tomorrow morning again and add a screenshot to the chat to give thr freetrade support something to work with . :+1:

I did try a few times to take a screenshot, but I was unable to - security settings on the app perhaps?

I’ll see what happens the next time I try a buy first thing :+1:

1 Like