Freetrade doesn't work iPhone SE

Have complained about this to them for months, and they keep saying an engineer is looking into it.

The Buy button on Freetrade via an iPhone Se doesn’t work - i can touch the Buy button 2,000 times and nothing happens, yes press the Sell button and it instantly works.

Have reinstalled the app, cleared the cache done everything in the possible world but they still cannot fix the issue.

Got to the stage where im going to have to try a rival app and this is unworkable.



Have you updated your iOS to the latest version?

Try scrolling the page so the button is further down the screen and then clicking.

I get the frustration though, especially if the sell button works okay.

Welcome to the forum

Thanks for raising this. I understand that there’s some fixes needed with the buy button and that these are particularly pronounced with the SE. The engineer was putting these into a release tomorrow so hopefully this will improve early next week. Feel free to ping me directly though if it persists so we can get to the bottom of this.


dorsnt work but sell button dors every single time

nope tried it still doesnt activate

tje button on the app doesnt move?

I have an iPhone SE and my buy button is there and works.

Hopefully but i doubt it as its been an issue for at least six months.

your lucky


I’ve been having the same issue now for about a week - but on both my iPad and iPhone. Sell button and all other buttons work, bar the ‘buy’ button !?

Have uninstalled and then reinstalled the apps on both devices and both running on the latest ios versions.

If this most basic of functions can’t be fixed soon, sadly I’ll be left with no choice but to transfer my ISA to a rival app.

1 Like

I have the issue as well. Seems to affect only one of my holdings (SAIN) - sell button works, the buy button does not. I’m on an iPhone 13 Pro.

Terminated and restarted the app several times and now it’s working again. Don’t know if that fixed it or something has been fixed on the back-end.

they told me months ago engineers were on it but they need new engineers!

Would seem that way…

@acamp Please can you advise asap when you think this issue will be fixed?

1 Like

Hey both

I’ve just flagged this to the team.

There are some issues with the buy button cropping up that we’re working on. These appear to be worse on the SE unfortunately.

Let me see what the team says.


1 Like

Thank you, @acamp.

Whatever you said or they did, it’s working again within minutes!:slightly_smiling_face:

Sorry to bother again @acamp but the problem seems to have returned. Strange, as after you’d had a word with the team the other day, it was working within minutes!?

Anyway, its just the buy button not functioning again, on both my iPad and iphone S6 (not SE). Appreciate if you could flag to the team again and try to get it permanently fixed. Thank you.

hmmmm, that’s not ideal @PeakOwl. The issue is a bit of a fiddly one to be honest, that’s why the team has had to try some different approaches to resolve it.

Let me flag this now in any case.

Sorry about this.