Required Android update not available

This is ridiculous!

Opening the Android app pops up a message saying “We have a shiny new version of Freetrade for you. You have to update now to continue.”

Clicking on the link you to the google store where there is no update available.

With shares prices all over the place at the moment, this could potentially be one of the best days of the year for buying shares. Can this be fixed ASAP?

I should also add that everything worked fine an hour ago.

I got the update but now can’t get into the app.

Had to do the update just now and can get into the app ok on Android - (App version 1.0.22525 (22525)

I had the same, I can get around it by clicking update, leave app open then when the Google play store opens just go back to the app.

Yeah I’m having issues. I even tried uninstalling the app and reinstalling, it still states I need to update

Found a way around this, when you get the popup, click update, it’ll take you to play store, then go back to the app and you’ll be in!

I cant update either. Tried uninstalling and reinstalling. Now cant access app.

Also got this issue on Android

We’ve just pushed a forced update live. If you don’t see it in the Google Play store, try force quitting the store and it should be there. Anything else, please shout so we can help out quick!

1 Like

Tried to log in.

Told to update to shiney new app.

Did this but when I press open, taken back update page.

Keep going round in circles.

Not so shiney as broken.

Please advise how to proceed

George Bowlt


It’s working for me. took me to play store. Tapped update there. it installed and now it works as before

1 Like

This is what I’m getting too

Kept trying and eventually it worked
For me but slow / frustrating

Thanks for the feedback everyone. There seems to have been an issue in the store pulling through the update for some users so we’ve paused this until that issue can be resolved. If anyone still has an issue, just shout!

Needed to update again and seems ok now