App closes on reading conversations

Anyone else having an issue that when you go to conversations with freetrade customer service in the app it shows all the conversations but shuts down when i try going into any.

Have reported this to freetrade as of yet no fix and no contact and to try and resolve this issue.

I am hoping they might finally fix this and hope its not just me having the issue.


I have the same problem with Gmails!

It’s not just you. I’ve been experiencing it for a while. I used to be able to fix it by force quitting and enabling “Clear data” in the iOS settings for the app but that doesn’t fix the issue anymore.

I’ve tried reinstalling and rebooting my phone and nothing is solving it.

Hi, I’m really sorry you’re seeing this issue when trying to access your conversations. We’re working on resolving this, and thought it would be helpful to provide a bit of context around what’s going on.

The issue seems to only be affecting a subset of customers, which is making it hard to reproduce. However we can see what the underlying cause of the crash is, and unfortunately it’s originating from the third party software we use to provide the chat feature in the app. We’ve raised this with them directly to see if it’s something they’re aware of or can suggest a workaround for, and we’ll continue looking for a solution ourselves.

In the meantime, we’ve had reports that starting a new conversation can resolve the issue (perhaps temporarily), allowing you to go into any of your old conversations without crashing. If you’re able to do this, please do give it a try and let us know if it worked for you. Otherwise, if you need to contact us please email from the email you use to log in to Freetrade.

Thanks so much for your patience while we look into this :pray:


Now you mention it, this might have been what fixed it for me the last time I started a conversation which happened to be about this issue preventing me from getting info from a previous conversation needed to chase up a pension transfer.

The workaround feels like a waste of Freetrade’s support resources for peeps to start new conversations which say “Ignore me, just trying to workaround an app bug to read my previous messages. Kthxbye” :grin:


Thanks for the update, but tried that when I reported this issue via the app to customer service and that didn’t resolve it.

My other issue is what about resolutions from my existing issue’s will i still get to the replies?

I have also been having the same issue with the App closing when I try to open an ongoing conversation. But at the same time I have had responses back to my questions and having re-booted my phone a few times I get to see the replies !