App down

Hello people. My freetrade app has not worked for over a week now.
Unable to log in.
Message says app down, we are working to fix it.
Is anyone else having this issue?
Any help or advice would be appreciated.

It is working fine for me. Perhaps try updating it? Do you pay freetrade monthly for fees and there is a payment issue?

Hi chris, i use the basic service which is free.
Ive unistalled and restalled the app, everytime i fill in the new details, after the final stage, it says there is an issue and we are trying to fix it.
But they been trying to fix it for ocer a week. Lol
Thanks for your reply anyway.
I have sent them a message, waiting for a reply.

Hi @Azhar786 sorry that you’re experiencing these troubles. Have you already completed registration for your account? If you delete and reinstall the app there should be an option to log in to your account by entering your email and receiving a “magic link” in your inbox.

Can you provide any more detail (a screenshot if no personal data) of the error message you get?

I can raise this with customer service to get you help.


Hi alex, hope the link works but this is the message i keep getting.
I have reinstalled the app and followed all instructions but i still cannot log on to be able to change any settings or view my accounts.

Thanks. Let me raise with the team and someone will be in touch via email.

I’ve been having a similar issue for the last week or so when trying to complete my sign up. Tried the in app help and emailing support. No response from either :slightly_frowning_face:

Hi @Jimjam

I’ve flagged this with customer service so someone can troubleshoot for you. Have you deleted and reinstalled the app for a start?

Also just an FYI but you may want to remove your email as your “name” on the forum as it’s publicly visible.


1 Like

Hi Alex,
I got it sorted, it was the wrong email.
All fixed now.
Try using old or new email, one or the other may work?
Good luck,

Thank you.
Will wait for some one to reach out, I’ve just tried again with a fresh install.