App not available?

I’m trying to sign up, but the app is saying "Something has gone wrong.

Freetrade is currently unavailable. We’re working to fix the issue, please try again later."

But it has been saying this for three days now. Is this a common occurrence?

Welcome to Freetrade! @JGHunter
The app on my phone is fine, have you tried:
A) Rebooting the device
B) Uninstalling and reinstalling the app
C) Reaching out to help@freetrade.io

I’m sure someone else will be along in a bit with alternative solutions!

3 Likes

So I tried sending another email and got an immediate rebound saying the email to that address was undeliverable!

Hi, thanks, yes I’ve tried all three. Haven’t had any response as of yet. Hopefully before long.

try hello@freetrade.io

1 Like

The only thing could be your phone. What are you using and what OS?

If you have a tablet or another phone you could try that?

Thousands of successful sign ups happen everyday.

Actually try the Mobile Network - The other day I couldn’t access the App using the WIFI but it seem to work on Mobile Network for some odd reason

1 Like

That’s what I was doing initially and that’s why I thought it wasn’t working, so left it until I get home to try wi-fi.

No worries, I’ll get through to support on the issue, thank you everyone

1 Like