Creating new account

For the past couple of weeks I’ve had issues signing up for a Freetrade account. I have tried using different email addresses, I have uninstalled and re-installed the app several times, I have been in touch with the Freetrade team who keep insisting that there are no technician issues with the app. But every time I try to sign up, I keep getting this notification (attached). Can I get any help on opening an account from this community/ has anyone experienced a similar issue and how did they manage this? Thank you :slight_smile:

If you’re using different emails maybe its the phone?

1 Like

Thanks for replying. I appreciate it. I don’t get what you mean, if the problem could potentially be with my phone how can I rectify this? x

1 Like

Try deleting the app, restarting the phone (avoids caching app data) and downloading it again. Try one more time this way :slight_smile:

Thanks for your help. I’ve just tried that now and I still haven’t had any luck. :confused:

The only other suggestion I would say is to see if you can borrow a friend’s phone or something and try with them there.

That would narrow down if it’s your details or your device at least.

So I’m guessing you have a reasonably new iPhone from the screen grab. My two guess would be -

Have you updated iOS?

Try clearing the data. You find it → Settings \ Freetrade (scroll down a fair bit)