Can't add funds to ISA

Hi fellow investors,

I opened an ISA account in Freetrade 3 days ago and managed to transfer £1 to verify the account. However, now I’m trying to top up 10k but when I get to the below screen and tap on continue nothing happens.

Any help would be much appreciated.


This is a known issue and being fixed urgently by the team

great thanks for letting me know. I hope it gets fixed before the ISA April deadline to add funds.

@Piltrafilla - Do you not have the option to use a reference number rather than Open Banking, to just manually send a payment to their account?

I think that would avoid this problem too :slight_smile:

@jasejase Do you know where to find that reference number, I thought it used to be an option on that screen, but I can’t see it.

It looks like this is fixed now (at least for me).
I did have to wait a couple seconds before tapping continue

I think the only way may be to delete the HSBC app so there is no app magic linking but I really don’t know if that would work temporarily.

Someone above has said it’s now working for them but they had to wait a few seconds. Worth trying again Luke?

1 Like

still doesn’t work for me :frowning: and there is no ref number to manually transfer funds from my online banking.

That’s the way I topped up my general account before so will follow your suggestion of removing the connection with the bank and see if I can see a top up from my bank.

Many thanks for the help

@jasejase thanks, yes I followed advice on another thread, and it works for amounts less that £1000.
Opens up the web browser version and not the banking app which is a little bit frustrating.

1 Like

Glad it worked for you. Hopefully they get it resolved soon.

There was an app update pushed out last night on Android. That maybe fixed the issue for me at least

1 Like

Just coming back to this thread to let you know that I finally managed to top up my ISA this week so I assume there was an issue with the app. Thank you all for your help.

Im a bit disappointed with the fact that Freetrade never replied to the email I sent them about this issue but I assume they had to deal with many of us asking the same and they didn’t have the means or tech to deal with them at scale.