Deposit issue

I’m asking on behalf of a friend. He’s trying to deposit money into his ISA, but pressing the bank transfer button does nothing. No next screen, no prompts. Any ideas what might be the issue?

Just a few Qs
What Phone is he using?
What OS version?
Is the App updated?
Assumed he’s turned off->on his phone?

This came up yesterday in another topic. Is your friend trying to add more than £1K? If he tries to add less than £1K does it work?

Yeah he’s using the latest version of everything, and tried rebooting.

Yeah he was trying to add more than 1k, is there a limit?

There is some kind of bug/issue, but if you stick to below £1K it seems to work. There is no specific limit that I’m aware of (it’s just initiating a bank transfer after all), but for some reason the button doesn’t work if it’s a large number.

This is the topic I was referring to:

1 Like

Thanks! He’s just tried £999 and it worked. At least he knows it’s not anything he’s done wrong, I’m sure freetrade will sort the issue soon.


I just tried it and it’s the same issue for me too.

Glad it’s not just me, I raised it with support this morning. It’s still glitchy even if you select an amount under £1000.