Deposit funds

I cannot deposit funds into freetade as I have dozens of times before. I select transfer from bank put in amount and press continue,and it does nothing. Usually it sends you to your bank


Happened the same to me earlier.

Went to my bank app and sent a transfer from there

1 Like

There is definitely something broken within the app, I’ve tried various denominations, 10/100/200/500. Sometimes it proceeds to the layer/confirmation screen sometimes not, most of the time it doesn’t respond at all.

I’ve just on boarded a friend and they’re struggling to add anything other than tiny amounts.

This is on android. @Viktor

The team are working on it. Thanks for the report!


Great! Love the service/app and in the process of moving my investments over, there’ll always be hick ups, but the fact you guys are in the forums responding and engaging where you can is really appreciated!

Same problem, I could not top up as usual. I have tried over the last couple of days from my usual bank. I tried £2000 many times. So then I tried with £100 and the continue button worked, so I tried £2000 and nothing happened (flicker on continue button only). So I tried £500 and it worked, and I transferred, then I did two £750 transfers and both worked. Strange bug, money not in ISA yet, but it has left my usual bank. Hope this helps.


i tried £500 and pressed the continue button rapidly several times at it works!
Thank you for the tip!
But another problem is now the app does not let me withdraw available money from my account. Weird… :confused:

Same here. Cannot top up. Is it related to a recent android app upgrade?

1 Like

I’m assuming it’s related to some issue with TrueLayer not processing amounts £1000 or over

you seem to only be able to do£500

Even doing £500 (which at least fires up the open banking / truelayer process) I still can’t put money into my ISA. It’s being rejected (showing as such in my Monzo app). No clue why. It’s been reported to Monzo and is being escalated in case they can tell me something.

Edit: Even a manual bank transfer is failing!? How odd… is the FT bank account closed?

Just tried/failed with £100 and £150 - the error message says the payees bank can’t accept funds.



Okay this is weird. Monzo have got back to me (swift service from them), it’s shown as Blocked by Beneficiary

I can’t even topup £100 but I was actually wanting to deposit £1000

Which bank are you with, @Micky?

Monzo but saying that, I’ve just tried again with £1000 and its worked


Tried about 7 times in the last couple of hours but seems to have gone through now

no luck here :\