Deposited money in to account for the first and after 11 hours there is nothing in my account can someone help

Deposited money in to account for the first and after 11 hours there is nothing in my account can someone help.

1 Like

Ask in the in-app chat first. Did you put the reference number in? If not they have to track it manually but they can if you ask. Otherwise it can in theory take a couple of days but should be quicker second time once the open banking knows you.

1 Like

Try the in app chat, customer support are great at FT. They will sort it quickly!

Ive tried to contact them but they are taking long to reply, and for the reference number it did it itself as i linked the account to my monzo

Ive tried contacting them around 12 today and no response

@sampoullain should be able to direct you. But don’t worry support will come back.

Hi Kyle

Please can you DM your email and we’ll check this out?

Sorry for the delay.

1 Like

Same here,
I deposited Friday and today but money doesn’t show in my account.
I contacted them in app and now I wait…:eyes::eyes::eyes::eyes:

Hi :wave:

Sorry to hear you’re still waiting for your deposit!

Could you drop me a DM with the email you use for the app and I’ll check this out for you?

1 Like

I wouldn’t post your email on a public forum.

1 Like

New here,I try to get my head around :joy:
Thank you.

2 Likes

I have replied to my welcome email, cc-ing hello@freetrade.io.

  • My top-up payments, more than 72 hours ago, have not been applied to my account.
  • I have no access to in-app chat.

Can I please get some assistance?

I have 7.90 Freetrade user #642,078 in my app and wanted to buy more Oracle or Ocado shares but after entering the amount I want to buy I can’t “Review order” is grayed out. So if I have £7.90 available to invest and why can’t I buy anything. so can you explain, I don’t want to put in anymore money from my account until the issue is resolved as other people seem to have similar problems. Not good for PR

The app is sometimes a bit rubbish like this, I’ve seen this once or twice over the last month. Try force killing the app and restarting it.

Of course, it’s the weekend and you can’t buy or sell anything at the moment, but you should at least be able to review the order, assuming you have enough “withdrawable cash” (see the account tab on the right). If your cash is unsettled (cash resulting from a sale takes 2 days to arrive) or reserved (you’ve set up a limit order), you can’t use it for anything else until those transactions have completed.