Isa error in photo

Anyone ever got this before. Suppose to have quite a bit in there.

Is it persistent or just a glitch?

Can you not see any balance anywhere?

The app sometimes lags on figures and charts etc.

1 Like

It can sometimes have a bit of a struggle in the “change accounts” list, especially when you have shocking wifi and a lot of different investments to update, but by the time you swap it’s usually sorted itself out. It’s nothing to worry about, better that than a very incorrect value being shown, tbh!

1 Like

Cant login to isa but gia is easy…

Customer service has been in touch reccomnding i should delete cache and data. Just not sure about what data ill lose

I got this exact problem in my GIA account today. Had a mild to medium panic then contacted support. None of their salves have worked. The support team assured me that the they can see the account as normal their end. Im still waiting for the problem to be solved.

1 Like

My gia is fine, looks like we have the samish problem but at different ends. Have you reset your app?

Deleted app, twice. Cleared cache and switched between data and wifi. Customer service were quick to reassure. But by all appearances, my shares have been half inched!

1 Like

Hope they wernt hacked or something…

Bit odd, have any of the stocks you have invested undertaken some form of unusual corporate action? (spin off, listing change or anything like that?). I do remember reading something where something similar-ish a while back

1 Like

Deltic have consolidated but that has happened to three stocks previously over the past month. Still unable to use GIA, market open. No word from Freetrade. They, I presume will still be happy to take my monthly sub without giving me the service.


Hey everyone :wave: Thank you for raising the issue you’re having on your apps right now. Our engineering team is aware of this and looking into it - will touch base once I get any updates from them. Thank you for your patience! :pray:

1 Like

Im back in to the GIA and so far it is working. Mildly irritated that I missed my chance is selling a couple of shares. However frustrating, customer support (Ellen) was on it! Very quick in responding and I really appreciated that. That was absolutely required (and recognised by Freetrade) as I was also in the process of stopping all bank cards - also had IT at company checking servers for hacks on wifi! Im very much aware of fraud and that kind error had me in quite a spin.

1 Like

Sorry to hear about the timing on this, Chris. Really appreciate your patience, and will be sure to relay your kind words to Ellen :blush: Glad to hear that everything is running smoothly again.

1 Like

If the issue is persisting for anyone else on this thread, can you please reach out to Customer Service at with your account info (email address) and device type, so the team can identify the underlying problem? Thank you! :pray:

1 Like

On a related note, this ‘bug’ reported a while ago could do with fixing…

Actually, this happens every time without fail when I switch between GIA and ISA. It gave me a jolt the first time it happened.