iPad APP stopped working AGAIN!


My iPad app has stopped working again! This is the 3rd time following FT updates!

iOS - 12.5.7
iPad Air
FreeTrade Version 3.9.65

I have tried offloading the app and re-installing, no change.

Why oh why do you push out an update without adequate software testing!!?

When n now open the app, the screen goes pinkish blank, then the iPad bombs back out to the apps page.

There are still notifications that are being diplayed by FT, the current number on the FT icon is 6!

How can I fix this? There doesn’t appear to be any version rollback at all? I’ve contacted the help via email and they just say, “We will get back to you” …and don’t!

Yes I flagged this to support last week…no timeframe given for fix

I’ve seen many other posting about it …yes, well over a week and no contact! Still without access!!

Hey :wave: I’ve followed up on this with our customer support team who has flagged this to engineering. They’re aware of the issue and are working on it as we speak. Will keep you posted with updates as soon as I can. Thank you again for your patience with this.

3.9.66 pushed out yesterday (31st May 2023) still doesn’t work.

If your ipad can only update to ios 12 you may have to give consideration to upgrading as time move forward and apple keeps updating its ios you may find that more and more apps stop working correctly. This probably isnt what you want to hear but there will probably come a point where there isnt anything freetrade can do to keep its app running on older ois.

That may be the case however if a company states the minimum requirements as:


Requires iOS 12.0 or later.

Requires iPadOS 12.0 or later.

Then I would expect the software to be FULLY tested based on this.

I do expect that they will indeed do as you say, but this has to come with a date and rollout to give people the chnce to either upgrade or leave.

1 Like

Steve, you are replying across two threads.

In the other thread Freetrade have explained the situation with Apple and the testing abilities of IOS 12. They have also stated that they we be running more manual testing so hopefully you are not in a similar situation moving forward.

Thanks – for anybody else coming to this thread, the post @Mattywallace is referring to is here.

@SteveFenton you’re right that we do officially support iOS 12 at the moment. For full disclosure, this is getting more difficult to support to the same level as more recent iOS versions, which you and a few others have noticed lately with your experience of being unable to launch the app – that’s definitely not the experience we want our customers to have!

We will do our best to maintain sufficient testing across all iOS versions. This is something we frequently review to ensure we can provide a good experience for customers on all the iOS versions we support.