Is there something wrong with Topping up from the App?

Handing off to the bank just fails at the “We are doing some Checks” stage.

Hi @Beechy

Sunday might be when someone is doing some maintenance? Maybe?

If it is deposited by the morning I’d drop a message or use in app chat if your a :plus_: user.

welcome to the community :ocean:

Thanks NeilB. Its been like it for quite a few days now. I did drop a line to the mail address. Lets see what comes back from that. My wife tried too and gets the same problem. I thinks its a problem that hasnt been picked up. Do you know if there is a link on this community that has the steps to make deposits direct from the bacnk account. I see some discussions but it doesnt seem to highlight the steps. Freetrade isnt a Payee on my account because I have always done via the top up mechanism. Many thanks for your reply.

Are you funding from a joint bank account? That caused trouble for me until I sent Freetrade a statement proving my name is connected to the account.


Have you tried this way? Truelayer appear to be illegitimately harvesting personal financial data whilst acting on behalf of Freetrade - #52 by vsn2020
Not sure if this still works due to age of the post. If not @Dave are you still doing non truelayer bank transfers, how do you get your reference number

Go the the screen with the list of banks and scroll right to the bottom, the option for manual transfer is there and you can get your reference number

1 Like

Dave. Apologies. Could you point me in the direction of the screen you refer to with the list of banks from which you can transfer funds please?

Go to account → Top up → Instant bank transfer. Input the amount and continue. A list of banks appears. scroll to the bottom for manual transfer. tap that and it gives you account and sort code and a reference number


Dave many thanks for your reply. That’s a really useful tip. Freetrade should document that on their site on how to top up (maybe they have and I have missed it). Thank you very much again.


I am replying to my own thread based on the current status of Top Ups from Freetrade. My own link via TrueLayer is still failing. I understand TrueLayer is a set of Open Banking APIs which is called by Freetrade. This page gives the status: My bank is GREEN yet its still failing. Dave Smiths post on “pushing” funds from your own account works but does lack some alerts from Freetrade (i.e. the activity log doesnt have the Top Up and there is no notification). My own case is slightly different as the hand off to true layer does display the Freetrade Sort and Account and the Reference number - so that is an appropriate way to top up in my eyes but does lack the comfort of the alerts. Would be good to have someone from Freetrade gather the error codes from Truelayer to see why its failing. It doesnt just fail for me but others too - so its not the app as I have re-installed. If anoyone from Freetrade looks at this then I would ask this is investigated please.

1 Like

Do you fund your joint bank account? My name was not connected to the account until I sent Freetrade a statement to prove this.

Malik. Thanks for your answer. I have been topping up fine until the last two weeks. I have never sent Freetrade anything to validate and I don’t use a joint bank account. Apparently quite a few people, although not all, are having problems. In the meantime I can do what has been suggested by Smith and make a payment the other way. It takes quite a while to credit though so you have to plan in advance. Apparently its being looked into but as of this week the error still exists.