New Account

Hi, If there are any moderators in the community section here, I am trying to set up a new account and wondered if there is either an issue with signing up, or, that there is currently a block on new accounts?

Thanks

Nottub

Moderators can only help with community/forum issues.

What kind of problem are you having creating a Freetrade account? Is there a message being shown?

AFAIK there are no blocks on new accounts.

Hi, no error messages. Just get stuck at the ‘Choose account type’ page. I select the ‘GIA’ button, the ‘Continue’ button becomes available which I click, then nothing the screen doesn’t change, just stays on the ‘Choose account type’ screen.

Tried shutting the app down, turning off the phone etc, but to no avail.

Nottub

Hmm. Odd.

I have read elsewhere a delete, reboot, re-download, apply process may fix this? Failing that, what phone/OS are you using?

It’s an Huawei P30 Pro running Android.

I’ll try the delete reboot process as well.

Thanks.

I wonder if this is a Huawei vs Google issue? I believe FT uses a number of google services, so if they are blocked due to the handset this may be the cause. I know this has been raised before, albeit for a slightly different model.

Ok tried uninstalling etc and still can’t process my application. Strange because this phone has all the Google sevices still installed (maps etc). The phone is about two years old, and I’m led to believe can still receive Google services.

Thanks

Nottub

I’m sorry I can’t help any further, this is beyond my area of expertise I’m afraid! Generally a reboot etc is all that’s needed in these kind of situations.

Hopefully someone else will come along who has had a similar issue or otherwise you may be best contacting Freetrade directly – hello@freetrade.io – to see if they can help, or speak to them via “the socials”.

Thanks for the suggestions.

Nottub

No problem. Best of luck joining up and getting into the world of investing.

I have a huawei p30. No problems with app but did take two weeks to get an account up and running

Hi Greg, managed to use my iPad to complete the registration, and I can now access the app on my phone. V strange.

However it’s complete.

Thanks for the info though.

Nottub

1 Like

interesting as i am suffering exactly the same. sign up on the android app will let me select an ISA account but the continue button if selecting GIA does nothing to advance the process at all.

i have tried deleting app, reinstalling numerous times but still no joy. for info i am on android 10 using a 1 year old xiami poco X3 NFC handset that runs google services as standard.

As mentioned, I managed to use an alternative device to initially set up my account. In my case an ipad.

An e-mail response from Freetrade suggested it was a known issue and being looked into.

Good news was that although I managed to set the account up on my ipad I had no problems accessing it from my P30. Seems to just get stuck at the account selection window on my phone.

Hope you get it sorted.

Nottub