Not able to set up an account

Hello , I am also having the same issue since last 48 hours , I am trying to register and i constantly get error message - " something has gone wrong. Freetrade is currently unavailable. Please try again later". I am not able to complete my account set up , can someone please help. Thanks

It’s impossible to diagnose a problem based on just a generic message from the app. There could be all manner of possible reasons for it.

Are you on Android or iOS? What OS version? What phone? Is it the latest version of the app? Are you running a VPN? Are you in the UK?

And that’s just for starters.

Hello , thanks for the reply. I am in UK , not running anything on VPN, I have a Samsung galaxy phone with latest android and OS version installed. The app I have downloaded is from the link got sent to me over the e-mail for first time registration. Thank you

So have you created an account and trying to log in, or have you yet to get that far?

Have you tried rebooting your phone?

Hi Tony,

So I am trying to create my account here , and after feeling all the details when I get to the last stage where you select the account type and finish. As soon as I press finish I get the error message and not able to do anything. I have already restarted my phone few times , I also uninstalled and re-installed the app few times but no luck.

Thanks
Abhi

Is it possible that the account creation has been successful, and you instead need to use the login option now rather than the “create an account” option?

Have you tried that?

It doesn’t look like the account is created because everytime i open the app , i have to go through the account set up procedure. Like passcode and then personal details etc. See attached screenshot it might be helpful , this is what I see after completing all the steps of account creation.

It does that if you try to log into a new device as well.

Your on Android 10?

@sampoullain could someone troubleshoot? If there’s one Android user having issues and it isn’t user error but a bug I imagine there’s more with the same issue.

If you’re not being offered to option to login, the app may be in a weird state of thinking you’re mid-way through submitting an application or something, and the submission fails because it’s already been done?

It’s entirely possible that your account has been created, but you just can’t access it because of this. I believe the way you get around this is to purge the app data and then delete and reinstall the app to force it out of this (there is something stored locally which tells the app what place it’s in so it goes back to that place every time you run it). Unfortunately I don’t know enough about the Android system to tell you how to purge the local data, but perhaps someone else will come along with that info.

Failing that, you may beed to contact FT directly.

1 Like

Hi Eden,

yes , I am on android 10 and I am not using any new device , I am trying to create my account for first time , so first time user.

Thanks
Abhi

Hi Tony,

Thanks again. I will give it a go by clearing out the cache and purge the app data , reinstalled it and will try again. I have contacted FT team many times but no luck , I am not getting any response back from them.

Thanks
Abhi

Unfortunately I think they’ve had a bit of a hill of requests over the new year and lots of staff off… they’ve usually been fairly prompt before the end of December.

Purging the app though might work, I’ve not had that issues specifically with freetrade but I have had that issue before on Android where removing it all fixed it for whatever reason.

All else fails start pining all the staff here :grinning_face_with_smiling_eyes:

2 Likes

I tried purging data and clearing out all the data , then uninstalled and installed the app again. It is still taking me back to the registration process and then get the error message as mentioned above in screenshot. I may just wait for the FT team to get back to me then , not sure what is the issue. @Eden and @tbutz thank you for help so far.

Abhi