Santander Top Up

I’ve tried several times to top up my account, all of my log on details are correct. But every time I get a oops something went wrong message. Any ideas?

:face_with_raised_eyebrow:I tried last night to top up another account I had with my Santander card.
It fail.
I just thought it was because I was buying Bitcoin. Maybe not

Are you using browser or the bank’s app to confirm payment? Have you tried the other? Also after you’ve gone through a bank app for payment, some Androids will give you the option of doing the next bit within the bank’s app (verification from Freetrade’s side)… for this bit I’m pretty sure you have to go to browser.

Going through truelayer, using the browser only and cannot top up my account. Using IOS device.

When I top up I tend to use the bank’s app for the first bit then browser for truelayer… that said I’m on Android. Have you tried asking Freetrade in-app? They usually get back to you in an hour or so, often less.

I’ll give the app a go again

I use the bank transfer and reference, it’s pretty much instant