Account access trouble_21-22Jun21_Resolved

I am unable to loginto my account and view shares today (21Jun21); it just keeps hanging and running circles

A few times I am able to login,but unable to scroll down and it freezes and crashes

Are there any known issues?

I am on a stable home wireless which otherwise works fine

I have restarted my phone thrice cleared out memory and space…so it does not seem to be a network speed issue or a phone space issue

I did not find any contact number to call for help

I have been using the freetrade app since a month, never a problem like today.

1 Like

There’s a problem at the moment if you are holding a lot of shares. If so, not a lot you can do about it, waiting for a fix. Same trouble here.


Thank you for the explanation.
I find it strange that there is no email or message notification about this
I am considering moving large investments onto Freetrade and this is serious!!!


Same here, just waiting for the fix.

With the app freezing on me, it’s meant that I’ve not looked at it so much today, which might be a good thing!

1 Like

No wonder everything is working fine for me! :cry:


Yeah it’s a real pain. If you are keeping check outside of the app, i.e., know what you want to do, you can still get in to buy and sell. Might take a few attempts but as soon as the app opens up, quickly tap discover. From there you should be able to manual search and buy sell from there.

Same problem here, pretty frustrating hope it gets fixed soon.

Mines been the same since the last software update, freezing up etc

1 Like

All the more important to get the web interface up and running … beacause i spent half the morning wondering if it was trouble at my end
mobile memory
disk space
app on the phone
before writing down this email
Admins: If you are listening the lack of communication is not useful; least is keep us all informed…so we dont panic … :rofl:


To be honest it crossed my mind it was under siege by a cyber attack, not for long… But it did cross my mind :unamused:

Menawhile had this late now as a response to my email to helpdesk and I tried them & they dont help at all
If you haven’t already, could you follow the troubleshooting steps below for me, please?

  • Turn off your Wifi, and use mobile data on full bars
  • Turn off your VPN (if applicable)
  • Uninstall & reinstall the app
    A UK market day lost… :roll_eyes:

@Doyin :point_up_2:

Helpdesk have requested me a recording of what is happening.?
When I tried it refuses to go beyond the first black screen
Occasionally it reaches the PIN screen and then goes blank beyond that in eternal red circles

My partner’s account (same wi-fi and same model) with 5 holdings works fine

Looks like a US market day lost too :angry:

I noted that the app has been updated on GooglePlay site today
I uninstalled and reinistalled : same problem… RUnning in circles… :angry:

Doesn’t inspire confidence does it.

1 Like

I am considering packing up; Day 2 and not much help; No web interface
Juvenile guidance on moving wireless to mobile network and reinstalling etc when the problem is much more serious and lies elsewere

They didn’t have a web interface when you joined, so I’m not sure how helpful it is to keep bringing it up. They can hardly magic one up out of thin air for you.

The “juvenile guidance” helps fix issues with mobile apps 90% of the time, so it was right of them to ask you to try these changes to see if it helped. That’s just how this works.

I find it odd it’s claimed to be about “holding a lot of shares”, which doesn’t make a lot of sense to me. If it’s about shares in many companies (meaning a lot of values to refresh) then how many are we talking? Twenty? Thirty? If it’s actually number of shares, then is it exceeding a display limitation? Which share specifically?

1 Like

Amount of companies. The problem appears to be with fetching the prices and mostly affects the portfolio display. Problem being that because the app defaults to that page on opening, you might not get in at all. How many companies? I don’t know how because I can’t stay in long enough to count before the whole thing locks up … but a guess is around 100

1 Like

Are all you folks using the Android version? (Just curious, I am not having any issues on iOS).

Android here