MEGATHREAD: Bugs & Glitches

Hi :wave:t2:

Please read this message before posting any issues you might be having. You might be able to fix your problem quickly by following the suggestions below.

This thread is for issues using the app, the community cannot help with account inquiries, these all need to be reported via in-app chat or

Before posting it’s worth following these few steps as they will often fix the issue:

Force close the app and reopen
Uninstall and re-download
Clear the cache (android)
Change between mobile data & wifi

When reporting an issue here please also make sure you email - the community is a useful resource however the customer care team will be the best placed to escalate your issue if it persists.

Please include in all reports the following (copy and paste if that helps)

Operating System -
Version -
Device -
Length of time you’ve been affected -

Good luck :sauropod: :ok_hand:t2:

hi haven’t been able to use the app all day today. just get the ring of death,also no profile and no chat feature so cant even report it or get any help from customer service. has this happened to anybody else?

1 Like

Hi there

sorry to be of no help

Mine seems to be workign fine


1 Like

thankyou for your reply and advice nielb , have followed your advice and still not working 3 days latter. waiting for a reply from freetrade support now.

1 Like

After recent update noticed that dividend related dates for the stock are listed

One of the good thing is you can add the dates to your calendar

But when select add to calendar its added to the following month though the date is correct.

Anyone else noticed this?


Tried it out with MWY and got the same result: it tried to add the Nov payment date a month later in Google Calendar. It’ll be a nifty feature though: great to have this info in-app.

1 Like

Yes I had to manually adjust the date before saving. I have a feeling one is counting months from 0 -11 while other is from 1-12 :slightly_smiling_face:


There is no problem with this capability on an iPhone. I can save to the phone’s own calendar and create an alert on the correct day. Sounds to me like a date-time compatibility issue.

As per the first post in this thread: Please can you provide some more information about your phone, OS and which app Version you are using. Also send support an email. I am sure the dev team will Thank you for finding the bug!

1 Like

Updated phone to ios 15.7.1 and got last FT app update.

I now can’t switch from GIA to ISA.

Have contacted FT to ask what’s going on.

I have the same issue, suddenly cant change to ISA account. Not updated anything.

Same here…

I have a message that the US market is currently closed and will open at 2:30pm (it’s 2:45pm uk time) and I can’t buy us shares.

Hope they havent been hacked

Yep, same

App is failing right now on both iPhone and iPad. Showing I am like almost 100% down and isa and gisa left with few pence.

Update please FT team @sampoullain

Not working on Android either (Pixel 5)

Same problem here. Can’t see or trade US stocks right now and it’s 3 PM UK time (30 mins after US market opened).

Yes, I have same issue
Anyone from freetrade here

Maybe if we had an official forum community manager, they might be able to let us know what’s going on.