Money has not been transfered

Hello all,

I made a topup 4 hours ago and it still hasn’t not been deposited?

Any help would be much appreciated

Mine is just stuck on the ‘processing top up’ screen. It’s a large amount of money (for me) that I’ve transferred from my linked account so I’m really worried.

@yvonnem My first top up went through, but now I have the same issue as you for my second top up…

Any money that has left your bank account and is with FT is not lost. It’s in queue waiting to be processed.

Yeah I tried to buy into 2 stocks last night and they’ve not completed but I was able to buy this morning on a different stock? Im also confused.

So I had to restart the app after it spent 5 mins on the processing payment screen, will this payment also go through?

On the back of that, I’m now a little concerned I’ve missed the price I aimed for because I chose this app and not Revolut.

If the money has left your bank account then it should go through. Give it 24 hours from the time you tried to transfer and then get in touch with support through the in-app chat. Waiting times are currently quite long due to a surge in new users.

1 Like

What does this have to do with the OP’s problem?
If you were buying volatile stocks then you may have to wait longer for completion.

Thank you very much for your help mate

1 Like